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     1. Introduction

      Project purpose:

The main goal of our project is to create an application that takes advantage of pen-based technology to encourage active and collaborative learning. Our application aims to increase interaction in classroom and to permit instructors to regain flexibility in teaching.

      Goals:

· This application is designed to be used in classroom facilitating note taking and sharing. 

· It is designed to annotate documents using a digital pen.  These annotations can be graphical (underlying lines , circles around a portion of text, bullets, checkmarks or other types of graphical objects ), or textual,  permitting the user to add hand-written text to the image.

· The system will have the ability to share annotated documents with other users through a local area network. These users will have the opportunity to visualize the images’ content , to add new content and to send back their response to the initial user.

      Web reference:   http://turing.cs.pub.ro/pen_tech/index.html
2. General description

Product description


This software is intended to improve natural interaction with electronic documents through the use of pen and digital ink. It's goal is to facilitate annotations on documents allowing handwritten complex notes taken on documents as well as creation of notes from blank pages. Particularly interesting is the “movie mode” feature described bellow which allows the user to see how a complex drawing had evolved when it was created.

Product features


In what follows we shall describe what features should be available to the user when  annotating documents.


The software must have at least the following features:

· create a blank page where annotations can be added

· load a locally stored image for annotation

· annotate the loaded image with different colors and line widths 

· save the annotated image locally and make it available through the web

· easily switch to next image in the folder or project

· easily switch back to previous image in the folder or project

· page erase, stroke erase functionality

· ask the user if he wants to save a yet unsaved annotation when a switch to another image is being made

· allow the user to define a project in which to include as many images as he likes and load them as a whole just by loading the project

· allow the user to optionally enter a username used to “sign” his own projects

· movie mode 

· the user has the ability to see the annotations as they progressed when they were made

· for this he chooses to enter movie mode when annotating an image, chooses “automatic save every x seconds” with the ability to set x to any value he wants or “save manually when asked” and then starts annotating the image

· the system will record the progress every x seconds as specified or when the user chooses if manual save is selected

· then, at a later time he can review the image with annotations in steps: first what has been annotated after x seconds, then what the image looked like after another x seconds etc


For a later stage of the project it is intended to add networking and collaborative capabilities to the project. Details will be set later, but those features will most likely include possibility to load the images from a centralized server, send annotated images to the server etc.

Categories of users


In the first stage the software does not distinguish among different types of users. Each user has the same features available to him as described in the Product Features section. 


However, if networking is added there will be a “teacher” who runs the server version of the application and several “students” who connect to the server. They will be able to load an image remotely from the server or submit their own annotations to the teacher – perhaps a blank page where the students write the response to a exercise given by the teacher.

Dependencies


In order to run the software the PC must have JRE 5.0 installed. JRE 5.0 is offered for free by Sun Microsystems for Windows, Linux and Solaris 
and can be downloaded from this website http://java.sun.com/j2se/1.5.0/download.jsp

Of course, the software also depends on having a functional pen with drivers properly installed.

Application overview

An overview of the application's menus is given below:

The File menu


Create Blank Image


Load Image


Save Image


Save Image As


Exit

The Edit menu


Undo


Redo

The View menu


Previous Image


Next Image


Image Erase

The Project menu


New Project


Open Project


Add File


Add Directory


Remove File

The About menu


About


Now follows a more detailed description of each feature of the software. Each section has a description and a usage scenario which tries to foresee all possibilities and indicate how the application must respond to each one.


A. Create a blank image


The user chooses Create blank page from the File menu or hits the button on the toolbar. The user is asked if he wants to add the new image to an existing project or create a new project from it and then a blank image ready for annotation is presented.


Accessed through:
File – Create Blank Image





Toolbar


Scenario:

1. Choose Create blank image

2. If current document has not been saved prompt for Save / Discard / Cancel

3. If user chooses Cancel



3.1. Come back to previous document

4. Else

4.1. Ask user if he wants to add the new image to an existing project, create new project with it or no project is associated

4.2. If user chooses Existing project

4.2.1.  Let the user choose an existing project

4.3. If user chooses New project

4.3.1. Let the user choose a name and location for the project file

4.4. Present a blank image to the user and allow him to annotate it


B. Load a locally stored image for annotation

The user chooses Load from the File menu or form the toolbar, a dialog box is presented inviting him to select a file to load. Only supported images file extension (.jpeg, .jpg, .gif) should be presented as default. When user clicks OK the image is loaded and available for annotations.


Accessed through:
File – Load Image





Toolbar


Scenario:

1. User chooses Load

2. Load dialog box pops

3. User chooses a file to load

4. If the file is an image in a supported format

4.1. If the image previously displayed was not saved since last modification ask the user if he wants to save it or not

4.2. Show the image in the main application window

5. Else

5.1. Present the user an error message describing that the selected file cannot be loaded


C. Annotate the loaded image with different colors and line widths


The user can choose form the left side of the screen a color and a line width. Any movement of the pen on the tablet when the cursor is on the screen drawing surface (where the loaded image is being displayed) will have an echo on the annotated image with the current color and width. The application should provide a default color of black and a default quite thin line.


Accessed through:
Left side Color Panel





Left side Width Panel


Scenario:

1. User has in the drawing surface a loaded image (possibly with some annotations from a previous use of the program)

2. User starts annotating the image. The program uses the defaults

3. User chooses a color; from now on annotations are done using this color

4. User chooses a line width; from now on annotations are done using this width


D. Save the annotated image locally


The user chooses Save from the File menu or the toolbar. A window pops and asks for a name and a location on the file system. If the image had been given a name already, the file with that is simply overwritten at each save.


Accessed through:
File – Save Image





File – Save Image As





Toolbar


Scenario:

1. User chooses Save

2. Application presents a save file dialog box

3. User chooses a path and name for the file

4. If the file doesn't exist 

4.1. The application saves the image together with the annotations made

5. Else

5.1. Ask whether to overwrite or not

5.2. If yes

5.2.1. Overwrite the existing file

6. Return to normal view of image


E. Switch to previous / next image


Using the two Previous and Next buttons or their corresponding entries from the View menu, the user can choose the previous or next image. Here next and previous have different meanings if the image is a part of a project or not. They will be explained in the scenario.


Accessed through:
View – Previous Image





Previous button under the drawing surface





View – Next Image





Next button under the drawing surface



Scenario – will be detailed just for Previous button, Next is similar:

1. User clicks Previous button or chooses Previous image from View menu

2. If a previous image does not exist the button/menu entry should be disabled

3. If the current image is part of a project

3.1. Check if current image is not saved and ask to save or discard

3.2. Display the image which was defined as previous in project order – note that the initial order is the order in which the images are inserted into the project, but it can be changed from the project view on the right

4. Else

4.1. Check if current image is not saved and ask to save or discard

4.2. Display the previous image from the current folder, where previous refers to alphabetical order


F. Stroke erase


From the toolbar or the Edit menu the user chooses Undo to erase the latest pen stroke or Redo to cancel to last Undo. The application should allow at least 3 Undo / Redo levels. A pen stroke is defined as a continuous move of the pen on the surface, that is without raising the pen from the tablet.


Accessed through:
Edit – Undo





Edit – Redo


Scenario:

1. User has an image loaded and annotated

2. User chooses Undo, the last stroke disappears

3. After user chooses 3 Undo's the menu entry and the toolbar button are disabled

4. In the initial state Redo is disabled

5. After one or more Undo's by clicking Redo the stroke that had disappeared comes back on the drawing surface

6. If there is no corresponding Undo, Redo is disabled


G. Image erase


The user can erase the entire page by clicking the Page erase entry in the View menu or the  corresponding button on the toolbar. This causes the whole image to disappear and be replaced by a white background.


Accessed through:
View – Image Erase


Scenario:

1. User clicks Image erase

2. Application asks « Are you sure »

3. If yes erase image

4. Else leave image in previous state

H. Allow the user to define a project 

Using the Project menu the user has the ability to define a project in which to include as many images as he likes and load them as whole just by loading the project. In the right part of the graphical user interface is a Project view window where the user can visualize existing images in the project, can add new images, can remove selected images , can move  a previously selected image one position up or one position down in the image hierarchy, all these by clicking the associated buttons. 

1)  The New Project from the Project menu offers the possibility to create a new project, with a chosen name and with a chosen location in the file system. Also the project can be set with a username and a password for restrictive access.

         Accessed through:
 Project – New Project

       Scenario:

1.  User chooses New Project

2.  A dialog window appears in which user can specify a name and a location for his project, and optionally a username and a password for this project

3. If user chooses Ok then a blank project with the specified path will be created. If a username and a password were provided the project can only be opened by using them, elsewhere  everyone has access to it.

4. If user chooses Cancel the operation will be aborted 

2)   Using The Add File option from the Project menu or the add button from the Project View user can add multiple files to his project.


Accessed through:
Project – Add File





Add button in right side Project View


Scenario:

1. User chooses Add File or clicks the add button 

2. A new window pops. Here the user browse through the file system and choose a directory from which to import  files. By default the window will show just the supported types of files in the specified directory. 

3. The user selects a file from the chosen  directory

4. If user presses Add  the file will be added to the project

5. Else if user presses Cancel  the operation will be aborted.

3) Using the Add Directory option from the Project menu user can add all the files from a directory to the current project. 


Accessed through:
Project – Add Directory


Scenario:

1. User chooses Add Directory

2. A new window pops. In this window the user browse through the file system and selects a directory whose files to import.

3. If user presses Ok all the supported files from the directory are imported in the project. Files with not supported extensions will be ignored.

4. Else if user presses Cancel  the operation will be aborted.

4) Using the remove button from the Project view window or the Remove Image entry in Project user can delete a previously selected image from his project.


Accessed through:
Project – Remove Image





Remove button in right side Project View


Scenario:

1. User selects the image he wants to delete by clicking on it in the Project view.

2. User clicks the remove button and the selected file will disappear from the Project view window and implicitly from the project.

5) Using the up button the user can move a previously selected image one position up thus changing the image hierarchy


Accessed through:
Up button in right side Project View


Scenario:

1. User selects the image he wants to move one position up by clicking on it in the Project view.

2. User clicks the button and the selected image will move one position up.

6) Using the down button the user can move a previously selected image one position down in the image hierarchy


Accessed through:
Down button in right side Project View


Scenario:

3. User selects the image he wants to move one position down by clicking on it in the Project view.

4. User clicks the  down button and the selected image will move one position down.

7) Using the option Open Project from the Project menu the user can open a specific project.


Accessed through:
Project – Open Project


Scenario:

1) User selects the option Open Project from the Project menu.

2) A window pops and the user browses through the file system and chooses a directory from which to import a project. Only the project files(with a certain extension) can be viewed and selected to be open in this window. The user selects the project he wants to open.

3) If user clicks the Open button in the window 

a) and the project has a user and a password set for it a new window appears asking the user to introduce the user and the password that will grant the access. After introducing these the project will pe loaded. If the user and password aren’t introduced correctly the acces to the project wil be prohibited

b) and the project hasn’t a user and a password set for it the project is opened and the files from it appear in the Project view




     4)  If user clicks the Cancel button the operation is aborted.

I. Movie mode

User chooses movie mode by clicking the button in the left toolbar. A window pops in which the user must select one of the following options (only one of them can be selected and by default it is selected the second one):

1. automatic save every x seconds where x will be introduced by the user

2. manually save 


All the generated images (manually or automatically) will have a name like Image_nameNumber  where Number denotes the number of the current generated image. These images will go in a directory named image_name-m which is in the same directory with the current project. A new project that includes the generated images will be created automatically. A special marker will be added next to the name of the page that generated the movie session indicating that there is a movie available for that page. By clicking the marker the project that contains the images taken in the movie session for that page will be available. The user can access the Next and Previous buttons to iterate through the images. The editing properties are disabled for a movie mode project so the user can’t modify the images and can’t create a movie session from them. He can only visualize them.


For the automatic saving mode, it is set an inactivity detection timer to avoid saving huge quantities of images in a movie session that a user may have had forgotten about. This way at a given period of time  since the last pen stroke was detected the movie session stops. A dialog window pops and announces the user that the movie session was stopped and for continuing it the user must press the OK button.

  Accessed through – Movie Mode view in the bottom left side of the application window

  Scenario:

1. User enters the movie mode. The Capture image and Quit movie mode buttons are inactive. If the user selects the first option with a value of x seconds and presses the Ok button the system will save the current state of the image every x seconds. The Quit movie mode button from the left menu  becomes active. 


1.1 To quit the movie mode the user clicks on the Quit movie mode button. The Capture image and Quit movie mode buttons are becoming inactive again.

2. Else if the user selects the second option and presses Ok the Capture image button and the Quit movie mode button from the left menu become active. When the user wants to save the current state of the  clicks on the Capture image button and an image is generated in a separate directory. 


2.1 To quit the movie mode the user clicks on the Quit movie mode button. The Capture image and Quit movie mode are becoming inactive again.

3. Else if the user selects Cancel the operation is aborted.

